Android 2.2 pour LG GW620 / Android 2.2 for LG GW620

A télécharger en bas / for download below


Une idée de défi qui me tient enfin en haleine : passer le ce téléphone lg en 2.2.

Pourquoi ? parce qu’il est vendu et (quasiment) bridé en 1.5. Vécu comme une réelle humiliation par la plupart des utilisateurs, qui ne peuvent bénéficier d’options (telles que le gps, Goggles, …), tous les autres téléphones sont promus à évoluer de version.

Je regarde actuellement la possibilité de remplacer leur travail. Pourquoi ? Trop occupés à promouvoir de nouveaux téléphones, télés ou des compétitions (dont tout le monde se moque éperdument), LG n’a pas une politique fidélisation de leur clients suffisante. Et étant de nature impatiente, je suis prêt à prendre des risques pour changer tout cela.

Pourquoi la 2.2 ? Si tu peux viser les étoiles, pourquoi viser la lune ?


An idea of challenge that keeps me breath holding: Move this LG phone under Android 2.2.

Why? because it is sold and (mostly) stuck in 1.5. Lived as a real humiliation for most users, who can not benefit from options (such as GPS, Goggles, …), all other phones are destined for an upper version.

I am thinking of the possibility of working by myself. Why? LG is
too busy to promote new phones, TVs or competitions (in which everyone could not care less), LG has no loyalty policy towards their customers. And my impatient nature is leading me to try to change it all.

Why Android 2.2 ? If you can aim for the stars, why aiming for the moon ?


Test : developers only.
Please be sure to make a complete backup before.
Do not forget a wipe of your userdata partition.
The sdcard is working… Better than nothing

21 réactions au sujet de « Android 2.2 pour LG GW620 / Android 2.2 for LG GW620 »

  1. Hello, i dont understand very well… but Libe you could succesfully create a booteable image of android 2.2 for LG GW620 or I’m wrong ??

    Saludos desde Santiago, Chile.

  2. Salut Thibaut,
    La maj n’est vraiment pas au point, même si elle fonctionne. Taper « tuto gw620 1.6 » sur google et prendre le premier résultat pour la marche à suivre.
    Je dois reconfigurer le démon rild pour au moins avoir le gsm qui fonctionne ! Et vérifier pourquoi le hardwareAudioInterface prend la version stub à la place du driver. En gros, le téléphone et le son ne fonctionnent pas.
    L’ihm marche mais bon, à quoi sert un téléphone sans telephonie ?

    Hi Thibaut,
    the update is not about to work, even though it’s booting. Please google « tuto gw620 1.6 » for a french tutorial about flashing your phone.
    I need to set up the rild daemon in order to get at least the GSM working ! And i need to check why the hardwareAudioInterface is handling a stub audio driver rather than the native one. To sum up, Telephony and Sound feature do not work.
    The GUI is working but you know, what is a phone without the possibility to call ?

  3. OK. I just saw that the Qualcomm ril library is also included in the Huawei U8220, recently updated to 2.1.

    Hopefully i can imagine porting it to GW620. Wait and see…

  4. Salut. Voila je me suis acheter le nouveau LGW620 j’ai voulu instaler l’android 2.2 sur ton site mais ca me dit que le contenu n’est pas pris en charge sur ce telephone et comme j’ai lu qu’il faller l’avoir pour beneficier de la derniere version du flash player… Pourrais-tu m’éclairer sur ce probleme stp ? Merci d’avance.

  5. Hello Libe

    Thank you for what your doing on GW620.
    I’m using GW620 in Korea.

    Hundreds of people told to LG ‘please upgreade it at least 2.1’ but they denied.
    (#$@#$#$)

    So, you and other XDA developer’s our last hope to get 2.x version.
    (In fact, In korea, mobile banking and stock and all other application is based 2.1
    I cannot understand LG’s thinking)

    Thank you!!!!
    Gracias!!!!!

  6. Bien joué !!!
    Bon courage pour la suite et merci de faire le boulot de LG
    On n’a pas la 1.6 alors pour la 2.2 on peut se brosser 😉
    Très bon téléphone mais mon premier et dernier LG car ils ne sont la que pour vendre, aucun suivi derrière.

  7. great job libe…i got a chance to install your ROM and couldn’t believe that this phone was running 2.2 =). so far are you having any luck with getting calling features?

    PS any chance you are working with any of the guys at xda forums on getting 2.x working?

  8. salut, je vais essayer un peu ton image,
    je ne suis pas developpeur du tout et encore moins android, par contre j’ai une grosse experience des firmwares realisés via openwrt , une forte connaissance de l’archi linux, et des heures de mae menuconfig sur les noyaux mips.
    je viens de me faire un chroot ubuntu sur le gw620 passé en donut 1.6 avec la rom realisee par zacpod.
    y a t’il moyen d’avoir quelques explications simples sur : ou tu recuperes l’arbre du projet android (codeaurora ; aosp …) et comment on merge les sources fournies par l’ami lg, qui ne fournit dans son paquet pas grand chose.

  9. voila, apres un premier essai de ton image, je n’ai pas reussi a faire de adb remount dessus, donc pas reussi a bricoler, peut tu monter directement l’image system en rw (dans les fichiers init.rc) pour les developpements, sinon android a l’air assez rapide pour etre utilisable,
    par contre j’ai vu que tu t’appuyais sur les sources du kernel 2.6.27, mais polytheus et zacpod fournissent du 2.6.29 provenant des sources fournies par lg, c’est dommage que les efforts de toi , polytheus et zacpod aillent de tous les cotés, car tu as reussi a booter de l’android 2.2 avec un vieux kernel, et eux ont reussi a faire fonctionner correctement du 1.6 avec le kernel 2.6.29 et tout le matos qui fonctionne.
    il faut donc viser au milieu : la 2.0 s’appuie sur le noyau 2.6.29 , je pense qu’il serait bien de commencer des efforts commun pour arriver a cela puis ensuite de passer a android 2.2.

    salutations.

  10. Salut !

    Je tiens à dire que tu as tous nos encouragements, les plus forts. ( il remarquale de voir qu’une personne comme vous entrevoit la lumière alors que LG donne l’impression d’être toujours dans le noir )

    Il est effectivement bien dommage qu’un excellent smartphone qu’est le LG GW620 soit pénalisé par une version dépassée d’Android ( perso , la non possiblité de transmettre les fichiers par bluetooth me laisse… perplexe surtout au vu de ce que offre ce téléphone)

    où en êtes vous avec le téléphone et le son …? la fonction caméra fonctionne t-elle?

  11. Bonjour, j’ai testé votre image en utilisant le tutos du flashing vers 1.6 sur forum.android.com.
    Mais malheureusement après tout ca quand je démarre Android, je me prend un kernel panic 🙁

    J’avoue etre un peu perplexe, tout le monde a l’air d’y arriver et c’est pas la premiere fois que je change la rom.

  12. i am new to rooting,can u get me complete set of instructions for rooting my gw620 to froyo,do 1.bluetooth file transfer 2.multitouch supported in the rooted model

  13. Hi guys, could please anybody describe the steps needed to make it done ? Or point me to some place where upgrade to 2.1 / 2.2 is explained the best way ? I am experienced linux admin but new to android. Thanks

  14. Olá Amigo,

    Primeiramente obrigado por seu esforço em atualizar o GW620, pois se dependecemos da LG estariamos ferrados!
    Mas graças a você e outros programados do XDA temos a esperança de ter uma nova firmware para nosso aparelho !
    Testei seu firmware e esta rápido, mas acredito que os motivos de não estar funcionando tantas coisas pode ser o kernel antigo, acredito que com uma parceria com o Polytheus , Zacpod , Tolemac e mais tantos outros programados do XDA vocês poderam concluir este belo trabalho !
    Parabéns amigo e Deus o abençoe pelo seu trabalho!

    Tom Nogueira
    .::- Brasil -::.

  15. Bonsoir j’ai un lgw620 le portable ma telment marqué mais j’ai vraiment deçu quand je me suis rendu compte qu’on ne pouvè ni envoyer ou recevoir de fichiers via bluetooth neanmoins je voudrais savoir si la version 2.2 est dispo si oui ou est qu’on le télécharger . merci

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

*